ci/flake.nix
gustavderdrache 5d6598ffda Pin CI tools with a flake
Also includes a .prettierrc, since later versions default to a single quote, which isn't the repo's style.
2025-04-23 14:52:21 -04:00

44 lines
980 B
Nix

{
inputs = {
nixpkgs.url = "https://flakehub.com/f/DeterminateSystems/nixpkgs-weekly/*";
# For action-validator, which is broken with new rust versions
nixpkgs-old.url = "https://flakehub.com/f/NixOS/nixpkgs/0.2411.717196";
};
outputs =
{ nixpkgs, nixpkgs-old, ... }:
let
inherit (nixpkgs) lib;
systems = [
"aarch64-linux"
"aarch64-darwin"
"x86_64-linux"
"x86_64-darwin"
];
forEachSystem =
f:
lib.genAttrs systems (
system:
let
pkgs = nixpkgs.legacyPackages.${system};
pkgs-old = nixpkgs-old.legacyPackages.${system};
in
f { inherit pkgs pkgs-old; }
);
in
{
devShells = forEachSystem ({ pkgs, pkgs-old }: {
default = pkgs.mkShellNoCC {
buildInputs = [
pkgs.nodePackages.prettier
pkgs-old.action-validator
];
};
});
};
}