mirror of
https://github.com/DeterminateSystems/ci.git
synced 2025-05-17 16:19:08 +02:00
Also includes a .prettierrc, since later versions default to a single quote, which isn't the repo's style.
44 lines
980 B
Nix
44 lines
980 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "https://flakehub.com/f/DeterminateSystems/nixpkgs-weekly/*";
|
|
|
|
# For action-validator, which is broken with new rust versions
|
|
nixpkgs-old.url = "https://flakehub.com/f/NixOS/nixpkgs/0.2411.717196";
|
|
};
|
|
|
|
outputs =
|
|
{ nixpkgs, nixpkgs-old, ... }:
|
|
let
|
|
inherit (nixpkgs) lib;
|
|
|
|
systems = [
|
|
"aarch64-linux"
|
|
"aarch64-darwin"
|
|
"x86_64-linux"
|
|
"x86_64-darwin"
|
|
];
|
|
|
|
forEachSystem =
|
|
f:
|
|
lib.genAttrs systems (
|
|
system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
pkgs-old = nixpkgs-old.legacyPackages.${system};
|
|
in
|
|
f { inherit pkgs pkgs-old; }
|
|
);
|
|
in
|
|
{
|
|
|
|
devShells = forEachSystem ({ pkgs, pkgs-old }: {
|
|
default = pkgs.mkShellNoCC {
|
|
buildInputs = [
|
|
pkgs.nodePackages.prettier
|
|
|
|
pkgs-old.action-validator
|
|
];
|
|
};
|
|
});
|
|
};
|
|
}
|