mirror of
https://github.com/DeterminateSystems/magic-nix-cache-action.git
synced 2024-12-23 13:32:03 +01:00
21c3863b07
Co-authored-by: Zhaofeng Li <hello@zhaofeng.li>
15 lines
369 B
Nix
15 lines
369 B
Nix
let
|
|
lock = builtins.fromJSON (builtins.readFile ./flake.lock);
|
|
|
|
flake-compat = builtins.fetchTarball {
|
|
url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
|
|
sha256 = lock.nodes.flake-compat.locked.narHash;
|
|
};
|
|
|
|
flake = import flake-compat {
|
|
src = ./.;
|
|
};
|
|
|
|
shell = flake.shellNix.default;
|
|
in
|
|
shell
|