magic-nix-cache-action/shell.nix
Graham Christensen 21c3863b07
Init the action
Co-authored-by: Zhaofeng Li <hello@zhaofeng.li>
2023-06-26 11:57:25 -04:00

15 lines
369 B
Nix

let
lock = builtins.fromJSON (builtins.readFile ./flake.lock);
flake-compat = builtins.fetchTarball {
url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
sha256 = lock.nodes.flake-compat.locked.narHash;
};
flake = import flake-compat {
src = ./.;
};
shell = flake.shellNix.default;
in
shell