nix/home-manager/common/software/cli/nixvim/alpha.nix
2024-12-03 10:29:00 -08:00

48 lines
2.2 KiB
Nix
Raw Permalink Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ ... }: {
programs.nixvim.plugins.alpha = {
enable = true;
layout =
let
centeredText = {
position = "center";
hl = "@comment";
};
mkPadding = size: { type = "padding"; val = size; };
mkText = text: { type = "text"; val = text; opts = centeredText; };
# mkGroup = val: { inherit val; type = "group"; };
# mkGroupItem = desc: shortcut: {
# inherit shortcut desc;
# command = "";
# };
in
[
(mkPadding 6)
(mkText ''
'')
(mkPadding 4)
(mkText ''
"Gordon doesn't need to hear all this,
he's a highly trained professional"
- Dr. Coomer PhD, 2000
'')
];
};
}