nix/lib/packages.nix
2024-12-01 18:58:26 +01:00

30 lines
863 B
Nix

{ inputs, system, unfree, repo, ... }: {
# Choose whether to pull from stable or unstable
pkgs = (import inputs.${repo} {
inherit system;
config = {
allowUnfree = unfree;
permittedInsecurePackages = [
"electron-27.3.11" # Logseq
# "olm-3.2.16" # Unknown
"dotnet-runtime-wrapped-7.0.20"
"dotnet-runtime-7.0.20"
];
};
hostPlatform = system;
});
# Some packages (ie, Vintage Story) I want to keep on unstable no matter what default repo I use
pkgs-unstable = (import inputs.nixpkgs-unstable {
inherit system;
config = {
allowUnfree = unfree;
permittedInsecurePackages = [
"electron-27.3.11" # Logseq
# "olm-3.2.16" # Unknown
"dotnet-runtime-wrapped-7.0.20"
"dotnet-runtime-7.0.20"
];
};
hostPlatform = system;
});
}