nix/shell.nix
2024-09-21 21:02:09 +09:00

24 lines
530 B
Nix
Raw Permalink Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ pkgs, sops-nix, ... }: {
default = pkgs.mkShell {
NIX_CONFIG = "experimental-features = nix-command flakes";
# imports all files ending in .asc/.gpg
sopsPGPKeyDirs = [
"keys/hosts"
"keys/users"
];
nativeBuildInputs = [
pkgs.nix
pkgs.git
pkgs.vim
pkgs.ssh-to-pgp
(pkgs.callPackage sops-nix {}).sops-import-keys-hook
];
shellHook = ''
echo ">>>> "
echo ">>>> Entering Nix Development Environment"
echo ">>>> "
'';
};
}